Профиль должен быть заполнен на русском языке кириллицей. Заполнение профиля заведомо ложными или некорректными данными - причина возможного отказа в регистрации на форуме.

DASMBSerial сбои связи

SCADA, серверы, АРМ верхнего уровня, диспетчерские

Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 07 апр 2016, 21:02

Добрый день, Такая ситуация DASMBSerial 2.5 по 485 подключен контроллер, все на столе (длинна кабеля минимум). Идут периодические сбои Item в диагностике то красные то зеленые. По истечение какого то времени (гдет-то порядка часа все нормализуется) и обмен продолжается сколь угодно долго, до следующей перезагрузки компьютера. После перезагрузки все сначало начинается опять пошли сбои. Похоже на программный дефект. После того как связь налаживается, остановка запуск сервера, проходят без последствий все опять начинает работать пока не перезагрузишь комп. Пробовал опрашивать контроллер модбас пулом на том же железе там тоже все нормально ни каких сбоев. Просмотр обмена тоже ничего не дал на аппаратном уровне похоже все нормально. Может кто то сталкивался?


Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 08 апр 2016, 08:27

$SYS$ErrorText пишет периодически PLC timeout $SYS$ErrorCode всегда ноль, $SYS$ErrorStatus меняется с 1 на 0.


Orshu
здесь недавно
здесь недавно
Сообщения: 23
Зарегистрирован: 17 янв 2012, 14:39
Ф.И.О.: Шуплецов Андрей Александрович
Поблагодарили: 2 раза

DASMBSerial сбои связи

Сообщение Orshu » 08 апр 2016, 16:33

что если с конфигурацией COM порта попробовать поиграть? (скорость чтения/передачи)


Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 08 апр 2016, 17:18

Да играл с ком портом (таймауты менял). Без результатов. Главное что интересно все нормализуется где то через 40 минут работы сервера, плюс минус пять минут. Делал уже три измерения время одинаковое.


Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 08 апр 2016, 18:02

Проблема по всей видимости в Windows 2008 server на котором все и было установлено. В Windows XP все вроде заработало нормально и сразу. Теперь думаю что сделать с Win server.


Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 09 апр 2016, 10:18

Проблема с Windows Server, сегодня провел такой эксперимент, запустил комп и подождал 40 мин потом запустил АРМ все заработало нормально. Майкрософт как всегда на высоте. Одно вызывает уважение к этой фирме, что столько лет такому количеству человек они умудряются впаривать никчемный продукт. Это не про обычных пользователей а профессиональное использование ОС.


LexSL
здесь недавно
здесь недавно
Сообщения: 42
Зарегистрирован: 16 дек 2011, 14:13
Ф.И.О.: Михайлов Алексей
Поблагодарили: 1 раз

DASMBSerial сбои связи

Сообщение LexSL » 11 апр 2016, 07:38

Vlad9 писал(а):Источник цитаты Идут периодические сбои Item в диагностике то красные то зеленые.


Была такая же проблема (Win 7 Prof) , причем точно знаю что линия связи RS-485 проложена по уму, скорость устройств не шибко большая (38400), возня с таймаутами результатов не принесла...
И по истечению некоторого времени все нормализуется, обмен идет без ошибок...(DASMBSerial 2.5)
Причем опрос через сторонние утилиты типа modpoll, terring modbus tool идет сразу и без каких либо ошибок.
В настройках DASMBSerial рекомендуют поставить Slow Poll Interval в 0 ms, однако сейчас не на объекте и попробовать на реальном оборудовании никак.
Может Вы попробуете, а потом отпишитесь...самому интересно, влияет ли данный параметр...


Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 12 апр 2016, 06:53

Я пробовал уменьшать это значение, обмен идет резвее но проблему это не решило, есть возможность это проделать, проверю отпишусь.


Автор темы
Vlad9
здесь недавно
здесь недавно
Сообщения: 25
Зарегистрирован: 28 дек 2015, 14:40
Ф.И.О.: Vasikov V V
Благодарил (а): 1 раз

DASMBSerial сбои связи

Сообщение Vlad9 » 12 апр 2016, 07:07

Тоже самое SlowPoll равно ноль, ни какой разницы. Я так понимаю тут какие-то внутренние тайминги влияют. 40 минут ждеш потом все нормально начинает работать как положено. Вот теперь ломаю голову как обойти эту проблему. Средств дополнительных нет что куплено больше уже ничего не купят. Бесплатных модбас серверов не нашел.Ставить более раннюю версию ОС с другим софтом боюсь будут проблемы, да и заказчик не одобрит. Пока решение опрос через другой контроллер у которого другой протокол и на борту есть модбас. Тут тоже есть трудности не могу плавающую точку победить.


Вернуться в «Верхний уровень автоматизации»



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость