Профиль должен быть заполнен на русском языке кириллицей. Заполнение профиля заведомо ложными или некорректными данными - причина возможного отказа в регистрации на форуме.

Проблемы с радиомодемом Невод

RS-485, ProfiBUS, 4-20 mA, Wi-Fi, GSM и так далее

Автор темы
tank_urg
почётный участник форума
почётный участник форума
Сообщения: 178
Зарегистрирован: 25 фев 2013, 06:14
Ф.И.О.: Шамилов Данис
Благодарил (а): 6 раз

Проблемы с радиомодемом Невод

Сообщение tank_urg » 10 июл 2014, 10:30

На этапе пусконаладки возникли проблемы при настройке радиосвязи. Пытаемся наладить связь между ПЛК (Невод + антенна Sirio SA-703N) и удаленной станцией (модем + антенна АН5-433). Протокол обмена - Modbus RTU RS-485.

Пробовали выставлять следующие настройки с помощью конфигуратора:
1) ПЛК + Невод + Sirio SA-703N:
la-
mb+
m0=2
gn=01
pn=01
ta+
ra+
2) Удаленная станция + Невод + АН5-433:
la-
mb+
m0=2
gn=01
pn=02
ta+
ra+

При выставлении перечисленных настроек связь отсутствует.
Параметры соединения выставляли следующие: 9600 бит/с, четность - нет, 8 бит данных, 1 стоп-бит.
В процессе наладки пробовали подносить шкаф с удаленной станции к шкафу, в котором установлен ПЛК, и соединять модули RS-485 кабелем напрямую, без использования радиомодемов, связь была в норме. При подключении же через радиомодемы связь отсутствует даже с учетом того что антенны Sirio SA-703N и АН4-533 находятся в непосредственной близости в прямой видимости, в нескольких метрах друг от друга.

Прошу помочь в решении данной проблемы.

Аватара пользователя

MuadDib
не первый раз у нас
не первый раз у нас
Сообщения: 359
Зарегистрирован: 31 июл 2010, 08:12
Ф.И.О.: Журавлев Павел Евгеньевич
Поблагодарили: 1 раз

Re: Проблемы с радиомодемом Невод

Сообщение MuadDib » 10 июл 2014, 10:47

Делали мы связь по Modbus RTU через "Неводы". Привожу наш конфиг:

Мастер

Код: Выделить всё

9600/8N1        433.200MHz 1800baud
rs=03h  bl=08h  rp=00h  sb=01h  ir+     tp=30h  cg=02h
gn=00h  pn=01h  ta+     ra+     la-     lp-     lf-     sp-     mb-
t0=00h  t1=00h  t2=00h  t3=00h  t4=00h  t5=00h  t6=00h  t7=00h  t8=00h  t9=00h
r0=00h  r1=00h  r2=00h  r3=00h  r4=00h  r5=00h  r6=00h  r7=00h  r8=00h  r9=00h
tt-     tl+     tn-     tc-     pm-     rt-     ld+     sc-
tt=32h  tl=02h  tn=0Ah  tc=0Dh  pd=FFh  rt=28h  td=05h  sc=7Ch
ch=00h  [04h]   br=00h  rm=00h  pa=04h  ar-     sw=00h
NO security key defined.


Слейв

Код: Выделить всё

9600/8N1        433.200MHz 1800baud
rs=03h  bl=08h  rp=00h  sb=01h  ir+     tp=30h  cg=02h
gn=00h  pn=02h  ta+     ra+     la-     lp-     lf-     sp-     mb-
t0=00h  t1=00h  t2=00h  t3=00h  t4=00h  t5=00h  t6=00h  t7=00h  t8=00h  t9=00h
r0=00h  r1=00h  r2=00h  r3=00h  r4=00h  r5=00h  r6=00h  r7=00h  r8=00h  r9=00h
tt-     tl+     tn-     tc-     pm-     rt-     ld+     sc-
tt=32h  tl=02h  tn=0Ah  tc=0Dh  pd=FFh  rt=28h  td=05h  sc=7Ch
ch=00h  [04h]   br=00h  rm=00h  pa=04h  ar-     sw=00h
NO security key defined.


С такими настройками у нас все работало как часы. Еще можно посмотреть положение джамперов (режим RS-485, подключение терминатора)


Автор темы
tank_urg
почётный участник форума
почётный участник форума
Сообщения: 178
Зарегистрирован: 25 фев 2013, 06:14
Ф.И.О.: Шамилов Данис
Благодарил (а): 6 раз

Re: Проблемы с радиомодемом Невод

Сообщение tank_urg » 10 июл 2014, 18:48

Спасибо! Будем пробовать.

Аватара пользователя

TEB
специалист по DEIF
специалист по DEIF
Сообщения: 7896
Зарегистрирован: 17 июн 2008, 15:01
Ф.И.О.: Евгений свет Брониславович
Благодарил (а): 36 раз
Поблагодарили: 63 раза
Контактная информация:

Re: Проблемы с радиомодемом Невод

Сообщение TEB » 10 июл 2014, 21:55

Еще невод в режиме прозрачного канала может оказаться не совсем прозрачным. У нас он глотал определенные байты, считая это своими командами. Смотрите весь трафик.
По вопросам работы Форума можно обратиться ко мне, или по этим контактам.

Аватара пользователя

MuadDib
не первый раз у нас
не первый раз у нас
Сообщения: 359
Зарегистрирован: 31 июл 2010, 08:12
Ф.И.О.: Журавлев Павел Евгеньевич
Поблагодарили: 1 раз

Re: Проблемы с радиомодемом Невод

Сообщение MuadDib » 11 июл 2014, 07:14

TEB писал(а):Еще невод в режиме прозрачного канала может оказаться не совсем прозрачным. У нас он глотал определенные байты, считая это своими командами. Смотрите весь трафик.


В конфиге, который я привел, отключены обработка спецсимволов и логическая адресация. Передача осуществляется по таймауту после последнего байта (tl+ , tl=02h). Это соответствует спецификации Modbus RTU: конец кадра определяется по "тишине" в линии. Ни на какие байты модем с такой конфигурацией особенным образом не реагирует.

Если неправильно сконфигурировать модем, действительно могут быть проблемы с реакцией устройства на отдельные байты.

Аватара пользователя

TEB
специалист по DEIF
специалист по DEIF
Сообщения: 7896
Зарегистрирован: 17 июн 2008, 15:01
Ф.И.О.: Евгений свет Брониславович
Благодарил (а): 36 раз
Поблагодарили: 63 раза
Контактная информация:

Re: Проблемы с радиомодемом Невод

Сообщение TEB » 14 июл 2014, 09:31

MuadDib писал(а):
TEB писал(а):Еще невод в режиме прозрачного канала может оказаться не совсем прозрачным. У нас он глотал определенные байты, считая это своими командами. Смотрите весь трафик.


В конфиге, который я привел, отключены обработка спецсимволов и логическая адресация.

Это совершенно не мешало Неводу в нашем случае глотать байты. А точнее было так. Определенные посылки у нас не доходили до адресата. Не каждая вторая или периодически, а именно определенные посылки. Начали смотреть трафик и увидели что в прошедшая через Невод посылка укорачивалась ровно на 2 байта, CRC при этом сохранялась естественно прежняя - поэтому посылка игнорировалась получателем как битая. Мы определили что дело не в том что в посылке встречается какое-то определенное слово (2 байта), которое определяется как команда. Дело было в том что после определенной последовательности байт - причем длину этой последовательности мы так и не определили - следующее за ней слово исчезало. Думаю что мы бы всё вычислили если бы задались целью, но на то и техсаппорт чтоб разбираться с такими вещами. Связались с тех.сапортом, объяснили проблему, на объяснение ушла где-то неделя т.к. на той стороне долго не могли воспроизвести. Воспроизвели, прониклись, ответили что устранят. Но на устранение ушло так много времени что мы перешли на другие модемы, и что там дальше - не знаю.

Просто предположил, раз был такой единичный случай - значит могут быть и другие подобные. Поэтому советую мониторить трафик.
По вопросам работы Форума можно обратиться ко мне, или по этим контактам.


Вернуться в «Интерфейсы, протоколы, связь»



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость