Профиль должен быть заполнен на русском языке кириллицей. Заполнение профиля заведомо ложными или некорректными данными - причина возможного отказа в регистрации на форуме.

Протокол МЭК-104

RS-485, ProfiBUS, 4-20 mA, Wi-Fi, GSM и так далее

Автор темы
Andrey V.
новенький
новенький
Сообщения: 1
Зарегистрирован: 02 дек 2012, 11:24
Ф.И.О.: @mail.ru

Протокол МЭК-104

Сообщение Andrey V. » 02 дек 2012, 11:37

Здравствуйте, уважаемые участники форума.

В данное время занимаюсь написанием драйвера протокола МЭК-104. Драйвер пишу для Simatic S7-400 на языке SCL.
Для начала от драйвера требуется хотя бы просто выполнять запрос на передачу данных от сервера данных.

Проштудировал всю серию стандартов МЭК 60870, в голове каша....
Установил на одном компе OPCclient, на другом 104slave.
Пытаюсь понять алгоритм работы 104-го через WireShark.

Так вот, подскажите, правильно ли я вижу последовательность запросов:



1. Синхронизация устройств (SYN-ACT SYN) задача канального уровня. Происходит автоматически.

2. Далее для контроля соединения выполнить TESTFR act-con.
Для первого раза считаю, что можно выполнить не по таймеру,
а сразу при подключении, для проверки соединения.

3. Открытие активного IP соединения – STARTDT act-con.

4. Запрос на передачу данных (C_IC_NA_1) act-con.

5. Прием данных.

6. C_IC_NA_1 завершение активации.

7. Передаем S(n), где n количество принятых кадров.

8. Ну и далее по таймеру T3 проводится TESTFR, пока не последует следующий запрос.

Предназначение TESTFR вроде понятно, но тогда для чего нужна тестовая функция C_TS_TA_1 (107). Отличие только в том что в C_TS_TA_1 есть метка времени?

Вот так я вижу как он должен работать... Поправьте/подскажите/посоветуйте!


stillbatt
новенький
новенький
Сообщения: 1
Зарегистрирован: 21 июн 2013, 10:08
Ф.И.О.: still mark

Re: Протокол МЭК-104

Сообщение stillbatt » 21 июн 2013, 10:16

Проверьте конфигурацию стороннего OPC-клиента на предмет того, какие тэги Kepware он опрашивает. Возможно, этот клиент обращается к каким-то неверно сконфигурированным тэгам. А когда вы запускаете QuickClient, вы, вероятно, просто не открываете ветку с этими тэгами, и поэтому ошибка не возникает.


Вернуться в «Интерфейсы, протоколы, связь»



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей