Профиль должен быть заполнен на русском языке кириллицей. Заполнение профиля заведомо ложными или некорректными данными - причина возможного отказа в регистрации на форуме.

В процессе работы пропали ОУ

Модератор: специалисты по Eplan


Автор темы
SilentGuest
здесь недавно
здесь недавно
Сообщения: 35
Зарегистрирован: 18 авг 2012, 20:59
Ф.И.О.: Petrenko Sergey Petrovitch

Re: Фатальные и прочие ошибки при работе с Eplan

Сообщение SilentGuest » 01 сен 2012, 08:13

Всем здравствуйте. У кого встречался такой глюк - в процессе работы пропали ОУ. Например клеммник Х1 из 10 клемм. Так вот, Х1 считается только та клемма у которой стоит ОУ. Остальные нумеруются цифрами без учета расположения и принадлежности к клеммнику. Аналогичная беда с контактами пускателей...

Аватара пользователя

AGorskiy
знаток Eplan
знаток Eplan
Сообщения: 2273
Зарегистрирован: 05 мар 2012, 14:00
Ф.И.О.: Горский Андрей Сергеевич
Откуда: Санкт-Петербург
Благодарил (а): 18 раз
Поблагодарили: 21 раз
Контактная информация:

Re: Фатальные и прочие ошибки при работе с Eplan

Сообщение AGorskiy » 01 сен 2012, 10:50

SilentGuest, это не глюк! Почитайте эту тему.
Все знания для всех. Поиск знаний священен. Обмен знаниями священен. Копирование священно.


Автор темы
SilentGuest
здесь недавно
здесь недавно
Сообщения: 35
Зарегистрирован: 18 авг 2012, 20:59
Ф.И.О.: Petrenko Sergey Petrovitch

Re: Фатальные и прочие ошибки при работе с Eplan

Сообщение SilentGuest » 01 сен 2012, 11:37

Спасибо, прочитал. Несколько не то. Вот, например у меня клеммник =ВО+ПСУ 1//ШКУ-ВО1-XT1:1, где название самого клеммника ВО1-ХТ1. Количество клемм 10. Так вот в процессе вставки клемм в схему, они отражаются как надо (т.е. ВО1-ХТ1:1, ВО1-ХТ1:2, ВО1-ХТ1:3 и т.д.) в процессе работы обнаруживаю, что клеммы получили имена :2, :3, :4, и т.д., а в навигаторе они считаются устройствами без ОУ.
Кстати, слетает это все дело в процессе табличной обработки

Аватара пользователя

AGorskiy
знаток Eplan
знаток Eplan
Сообщения: 2273
Зарегистрирован: 05 мар 2012, 14:00
Ф.И.О.: Горский Андрей Сергеевич
Откуда: Санкт-Петербург
Благодарил (а): 18 раз
Поблагодарили: 21 раз
Контактная информация:

Re: В процессе работы пропали ОУ

Сообщение AGorskiy » 01 сен 2012, 12:57

SilentGuest писал(а):что клеммы получили имена :2, :3, :4, и т.д

Странно, такие сокращенные ОУ появляются как раз в том случае, когда слева или сверху (как настроено в рамке) первое ОУ.
Ваш вариант не смогу в ближайшее время проверить, но если кто-то из пользователей подтвердит, что данная ошибка (та ситуация которую вы описали) появляется в результате Табличной обработке верну сообщения в тему ошибок. Для чего используете табличную обработку?
Все знания для всех. Поиск знаний священен. Обмен знаниями священен. Копирование священно.


Автор темы
SilentGuest
здесь недавно
здесь недавно
Сообщения: 35
Зарегистрирован: 18 авг 2012, 20:59
Ф.И.О.: Petrenko Sergey Petrovitch

Re: В процессе работы пропали ОУ

Сообщение SilentGuest » 01 сен 2012, 13:08

AGorskiy писал(а):такие сокращенные ОУ


Это не совсем сокращенное ОУ. В моем случае получается клемма вообще без ОУ. Т.е. она не принадлежит никакой установке, месту установки, номеру установки. Так называемая "глобальная переменная". Табличную обработку использую потому что схемы одинаковые только номера механизмов разные. Сделал несколько макросов и вперед. Обратил на это внимание когда листов 100 сделал.

Аватара пользователя

GenderGeek
здесь недавно
здесь недавно
Сообщения: 12
Зарегистрирован: 10 авг 2012, 19:44
Ф.И.О.: GenderGeek
Откуда: НеСкажуКакойГородНаНеве

Re: В процессе работы пропали ОУ

Сообщение GenderGeek » 01 сен 2012, 17:24

Sergey, кажется в результате табличной обработке вы допустили ошибку. Сейчас под рукой нет Еплана, но почему было не использовать внешнюю обработке в Экселе? Так косяков при обработке почти нет.


Автор темы
SilentGuest
здесь недавно
здесь недавно
Сообщения: 35
Зарегистрирован: 18 авг 2012, 20:59
Ф.И.О.: Petrenko Sergey Petrovitch

Re: В процессе работы пропали ОУ

Сообщение SilentGuest » 01 сен 2012, 18:53

Да может и допустил... Ранее также пользовался табличной обработкой, такого не наблюдал. По поводу Excel'я не совсем понял структуру передаваемых данных. Посему не рискую. Проект уже на выходе. Ранее пытался с базой изделий и соединениями. Не получилось..
Только какая ошибка при табличной обработке??

Аватара пользователя

MIvanov
знаток Eplan
знаток Eplan
Сообщения: 362
Зарегистрирован: 05 мар 2012, 13:46
Ф.И.О.: Иванов Максим Евгеньевич
Откуда: Казань
Контактная информация:

Re: В процессе работы пропали ОУ

Сообщение MIvanov » 03 сен 2012, 06:52

Пользовался табличной обработкой неоднократно, такого не было. Могут быть проблемы если используете символ ":" в качестве структурного идентификатора. Нужны скриншоты макросов, и участков схем с проблемными клеммами.
Максим умер. Прочитайте пожалуйста это сообщение viewtopic.php?f=78&t=3947&p=34780#p34703


Вернуться в «Архив»



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей